Volkswagen Owners Club Forum banner
video
1-8 of 500 Results
Advanced
  1. Golf MK7 / 2015 and up
    Hey guys, So I took my Golf in for its 110,000 mile service last week and thankfully no issues to report. I got a new VW Polo courtesy car that was actually not too bad. I made a video on the car if anyone wants to check it out? [/YOUTUBE]
  2. Beetle Newbs / FAQs
    Hi all, ever since we bought our beetle back in 2015 we have never had good DAB reception (UK DIGITAL RADIO). We are both avid DAB listeners and really miss this feature from our old car. I am aware the antennas are the lines on the front windscreen (which i think is super silly), is there...
  3. 1975 - 1984 VW Rabbit General Forum
    Good evening! I have a 1980 Volkswagon Rabbit (Diesel). ISSUE: Battery dies within a day or two after a full charge. BACKGROUND: For a few weeks now, I noticed the battery light come on but illuminate like a dancing strobe light. Seemed to be intermittent when it came on. Sometimes it'd be...
  4. Passat B7 Forums
    Hi there, I have a problem with my B7 Passat Cc that is more than annoying. The engine won't crank but all the lights and radio work. Unfortunately I cannot post the youtube link with the video but you can find it by typing on Youtube: VW PASSAT B7 CC IGNITION PROBLEM
  5. General Volkswagen Discussion
    Hello. I changed the oil in my golf 3, 1.4L, 1997, and 2 weeks passed since. After i changed the oil, the oil light got on and it stayed like that until the engine got warm. It does the same thing every time i start the car. I took the car to a mechanic, and he sayed that he doesn't know why...
  6. CARiD.com
    https://www.youtube.com/watch?v=IAWB9wpUwn4 Hello guys! Today we are here with the new video review on Injen release - EVO3000 Evolution Series Rotomolded Black Cold Air Intake System with Dry Blue Filter. Injen is among the most well-known brands in the custom air intake systems industry and...
  7. GTI MK7 / 2015 and up
    So I have a 2016 GTI, since I’ve had it I’ve had nothing but problems with the push button start. Every time I take it to the dealer I tell them about the issue and they always say, it works good for us. I’ve taken video of me trying to start and turn off the car, some of these are over a minute...
  8. TIGUAN OWNERS CLUB
    Hi Peeps I have just bought a 2008 Tiguan and I am having issues with the Aux lead. Firstly, When try to connect via bluetooth to Spotify, it misses parts of songs, like the connection is not quite right. Hence reverting to the Aux lead. When I plug the lead in and try to connect via this...
1-8 of 500 Results
Top