Volkswagen Owners Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm new to this site and have done some searching, but have not found an answer to my scenario, so here goes - I just bought a 2.0L Gasoline 1999 Golf Wolfsburg Edition (early body style). Someone swapped the automatic transmission out and put in a 5 Speed Manual. It runs good, but the check engine light is on and the codes are all automatic transmission related (shift solenoids and shaft speed sensors). Here in Texas, it will not pass Emissions Inspection with the light on. I called a local import salvage yard to see if they had an ECM for a manual car, and he told me that the ECMs were the same for either transmission, and all I had to do is locate the TCM right next to the ECM and just unplug and remove it. Well, I removed the exterior cowl grille and found what I assume is the ECM, but there is no TCM there. My questions are:
1) is it as simple as removing a TCM?
2) If it is, where is it located?
3) If it is not, is there anyone out there who knows where an ECM for this engine/transmission combination is available?
4) If there is not a TCM and the ECMs are the same for both transmissions, is there a way to reprogram my ECM for the manual transmission?

Any help will be greatly appreciated!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Found out after searching some more online that the TCM is located under the left side back seat bottom. I removed the TCM and all of the transmission codes are gone, but now a P1613 is coming up. After researching that code some, it appears that it may be set by the ECM not being able to communicate with the TCM. The saga continues......
 
1 - 2 of 2 Posts
Top