Volkswagen Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi i have just put a turbo in my 06 golf gttdi as the last one had chewed away at its self. A am leeting the oil burn off itself as it went into exhaust the lot, ia not getting loads off power tho and loosing power when getting over 3000 revs and help would be great
 

·
Registered
Joined
·
57 Posts
Hi there,

Did your old turbo blow up meaning the turbines shredded?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
57 Posts
Ok I had the same car many years ago and done the same thing, I ended up going through 2 turbos because i didn’t get the inter cooler cleaned out and had to get a new one.. not saying this is your issue but sounds very familiar.. so your car going into limp mode? Because that’s what it sounds like from what you described If so you’ll need to check the turbo again for any issues.
Basically any bits of metal from the previous turbo blow out can works way back to the new one and damage it..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Ok I had the same car many years ago and done the same thing, I ended up going through 2 turbos because i didn’t get the inter cooler cleaned out and had to get a new one.. not saying this is your issue but sounds very familiar.. so your car going into limp mode? Because that’s what it sounds like from what you described If so you’ll need to check the turbo again for any issues.
Basically any bits of metal from the previous turbo blow out can works way back to the new one and damage it..


Sent from my iPhone using Tapatalk
Ok thanks a will have to have a look, it just is taking ages to get upto speed then when hets to 3000 plus then its just not going any higher.
 

·
Registered
Joined
·
57 Posts
I hope you get it sorted as I know it really pissed me off when it happened to me.. good luck.


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top