Volkswagen Owners Club Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi I ended up getting a MK4 Golf GTI 2.0 manual and I’ve had an issue recently where sometimes my turn signals would stop working but my hazards still work anyone know what this might be ?
 

·
Registered
Joined
·
259 Posts
Switch is gummed up. I had this problem just this past weekend on a Ford Ranger. I could not get the meter I was using to verify continuity across the turn signals but did get the wiper and headlights to show contacts. I took the whole switch apart and the copper tabs that do all the connecting were just green with corrosion.
A quick clean with some jewelry cleaner, a wire brush and WD 40 and I was good to go. It is a pain to remove all the dash stuff and all but the new switch was 40 bucks and I would have had to pull all that stuff anyway. I did need a very small #10 torque head but I have one of those sets that have like 100 different bits in it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Switch is gummed up. I had this problem just this past weekend on a Ford Ranger. I could not get the meter I was using to verify continuity across the turn signals but did get the wiper and headlights to show contacts. I took the whole switch apart and the copper tabs that do all the connecting were just green with corrosion.
A quick clean with some jewelry cleaner, a wire brush and WD 40 and I was good to go. It is a pain to remove all the dash stuff and all but the new switch was 40 bucks and I would have had to pull all that stuff anyway. I did need a very small #10 torque head but I have one of those sets that have like 100 different bits in it.
Thank you I’ll try it
 
1 - 3 of 3 Posts
Top